Welcome to Squishdot Websites Squishdot How-To
 about
 search
 post article
 Documentation
 Mailing Lists
 Bug Tracking
 Development
 Installation
 Upgrading
 Download
 admin
 rdf

 main


Migration problems
Squishdot Posted by Kevin Jardine on Monday May 21, 05:49PM, 2001
from the moving-on-up dept.
We're migrating a relatively large Squishdot 0.7.2 site (about 6000 postings) to Squishdot 1.1.0 (and soon, 1.2.0!).

So far as we know, we have followed all the upgrade instructions, but in our testbed site, all searches fail with a Key Error on thread_path.

Does anyone have a patch or suggestion to fix this?

The traceback is:

Traceback (innermost last):
File /home/zope/Zope/lib/python/ZPublisher/Publish.py, line 223, in publish_module
File /home/zope/Zope/lib/python/ZPublisher/Publish.py, line 187, in publish
File /home/zope/Zope/lib/python/Zope/__init__.py, line 221, in zpublisher_exception_hook
(Object: Traversable)
File /home/zope/Zope/lib/python/ZPublisher/Publish.py, line 171, in publish
File /home/zope/Zope/lib/python/ZPublisher/mapply.py, line 160, in mapply
(Object: search)
File /home/zope/Zope/lib/python/ZPublisher/Publish.py, line 112, in call_object
(Object: search)
File /home/zope/Zope/lib/python/Products/Squishdot/SquishSite.py, line 817, in search
(Object: Traversable)
File /home/zope/Zope/lib/python/OFS/DTMLMethod.py, line 189, in __call__
(Object: showSearchResults)
File /home/zope/Zope/lib/python/DocumentTemplate/DT_String.py, line 538, in __call__
(Object: showSearchResults)
File /home/zope/Zope/lib/python/DocumentTemplate/DT_In.py, line 717, in renderwob
(Object: search_results)
File /home/zope/Zope/lib/python/DocumentTemplate/DT_Var.py, line 276, in render
(Object: thread_path)
KeyError: (see above)

<  |  >

 

Related Links
  • Articles on Squishdot
  • Also by Kevin Jardine
  • Contact author
  • The Fine Print: The following comments are owned by whoever posted them.
    ( Reply )

    Hmmm...
    by Chris Withers on Monday May 21, 07:41PM, 2001

    This is generally a sign that the Catalog is doing something bad.

    What version of Zope are you using? I'd recommend 2.3.2...

    Also, double check you've done all of the steps in the upgrade docs.

    cheers,

    Chris

    [ Reply to this ]
    • Re: Hmmm...
      by Kevin Jardine on Tuesday May 22, 01:51PM, 2001

      I've just installed Squishdot 1.2.1 and all our problems have gone away.

      Perhaps, as you suggested, I missed a step somewhere in the previous upgrade. In any case, it appears to be fine now. And, yes, we are using Zope 2.3.2.

      We're going to hammer on our test site for a few more days, and then migrate our real Cybercentre. Thanks again for the great software, Chris!

      Cheers, Kevin


      [ Reply to this ]
      • Re: Hmmm...
        by Chris Withers on Tuesday May 22, 03:01PM, 2001

        Pleasure :-)

        Let me know how you get on...

        cheers,

        Chris


        [ Reply to this ]

     
    The Fine Print: The following comments are owned by whoever posted them.
    ( Reply )

    Powered by Zope  Squishdot Powered
      "Any system that depends on reliability is unreliable." -- Nogg's Postulate
    All trademarks and copyrights on this page are owned by their respective companies. Comments are owned by the Poster. The Rest ©1999 Butch Landingin, ©2000-2002 Chris Withers.