Welcome to Squishdot Squishdot How-To Newbies Websites
 about
 search
 post article
 Documentation
 Mailing Lists
 Bug Tracking
 Development
 Installation
 Upgrading
 Download
 admin
 rdf

 main


Catalog splitter encoding error
Newbies Posted by Jimmy Wong on Wednesday April 30, 02:11AM, 2003
from the Upgrade dept.
I upgraded to the 1.5.0 upgrade and ran the 1.4.x_1.5.0 updater but got an error. Now my searches cannot find any posts.

I'm using Zope 2.5.1 with Python 2.1.3 on Win2k. I had Squishdot 1.4.1 with no problems. I installed the Squishdot 1.5.0 upgrade, and ran the 1.4.x_1.5.0 updater per readme instructions (I've successfully run the updaters since version 0.3, so updating is not a new thing for me). However, this time, the updater produced this error message:

Processing 'uoe'
An error occurred when processing 'uoe'
Type:exceptions.TypeError
Value:Splitter() got an unexpected keyword argument 'encoding'

I restarted the Zope instance and this time I got the "Fixed indexes and re-catalogued." message from the updater. However the postings still were not searchable.

In the Squishdot site, in the Options tab, when I click on the 'Re-Catalog All Postings' button, I get the following error message:
Error Type: TypeError
Error Value: Splitter() got an unexpected keyword argument 'encoding'
Traceback (innermost last):
File D:\PROGRA~1\zope251\lib\python\ZPublisher\Publish.py, line 150, in publish_module
File D:\PROGRA~1\zope251\lib\python\ZPublisher\Publish.py, line 114, in publish
File D:\PROGRA~1\zope251\lib\python\Zope\__init__.py, line 159, in zpublisher_exception_hook
(Object: uoe)
File D:\PROGRA~1\zope251\lib\python\ZPublisher\Publish.py, line 98, in publish
File D:\PROGRA~1\zope251\lib\python\ZPublisher\mapply.py, line 88, in mapply
(Object: recatalogPostings)
File D:\PROGRA~1\zope251\lib\python\ZPublisher\Publish.py, line 39, in call_object
(Object: recatalogPostings)
File D:\PROGRA~1\zope251\lib\python\Products\Squishdot\SquishSite.py, line 151, in recatalogPostings
(Object: uoe)
File D:\PROGRA~1\zope251\lib\python\Products\Squishdot\Posting.py, line 71, in index
File D:\PROGRA~1\zope251\lib\python\Products\ZCatalog\ZCatalog.py, line 480, in catalog_object
(Object: uoe)
File D:\PROGRA~1\zope251\lib\python\Products\ZCatalog\Catalog.py, line 367, in catalogObject
File D:\PROGRA~1\zope251\lib\python\Products\PluginIndexes\TextIndex\TextIndex.py, line 314, in index_object
(Object: title)
TypeError: (see above)

I wasn't able to find any useful information on Google on how to fix this problem. Would anyone be able to help me with this? Thanks.

-Jimmy

<  |  >

 

Related Links
  • Articles on Newbies
  • Also by Jimmy Wong
  • Contact author
  • The Fine Print: The following comments are owned by whoever posted them.
    ( Reply )

    Re: Catalog splitter encoding error
    by Chris Withers on Friday May 02, 05:10PM, 2003
    I suggest you search the Zope mailing list archives.
    I've seen this error before but I can't remember the cause or the solution...

    cheers,

    Chris
    [ Reply to this ]
    The Fine Print: The following comments are owned by whoever posted them.
    ( Reply )

    Powered by Zope  Squishdot Powered
      "Any system that depends on reliability is unreliable." -- Nogg's Postulate
    All trademarks and copyrights on this page are owned by their respective companies. Comments are owned by the Poster. The Rest ©1999 Butch Landingin, ©2000-2002 Chris Withers.